import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(754|1231)|[^A-Za-z\\s]";
final String string = "Dividends 9672\n"
+ "Dividends 9680\n"
+ "Interest Income\n"
+ "Ordinary Dividends\n"
+ "Royalties\n"
+ "Capital Gain Distributions\n"
+ "Income from Blackstone\n"
+ "Ordinary Income\n"
+ "Rental Income\n"
+ "Long Term Capital Gain\n"
+ "Short Term Capital Gain\n"
+ "1231 Gain\n"
+ "Section 754 Stock Basis Adjustment - 2015\n"
+ "M-1 Section 754 Stock Basis Adjustment - 2015\n"
+ "Section 754 Stock Basis Adjustment - 2018\n"
+ "M-1 Section 754 Stock basis adjustment - 2018";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}