const regex = /https?:\/\/[^"]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/[^"]*', '')
const str = `{ "uploadUrl": "https://streetviewpublish.googleapis.com/media/user/11705162112362643904472027/photo/899853939832211842569886" }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}