using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<key>[^=;\r\n]+)=(?<value>""[^""]*""|[^;\n\r]*);?(?<comment>.*)";
string input = @"This=""isnot;acomment""
This=""isa"";comment
This=""isa;special"";case
This=isasimplecase
This=isasimple;comment
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}