import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A(?:^(?!.*\\bLecture\\b).*\\r?\\n)*|^\\r?\\n|^.*\\r?\\n(?![\\s\\S]*\\bLecture\\b)";
final String string = "My Dashboard\n"
+ "Fnfjfjf. random test\n"
+ "00:50\n\n"
+ "1:01:56\n"
+ "My Notes\n"
+ "No data found.\n\n"
+ " \n"
+ "Change Language + English \n\n"
+ "Submit\n\n\n"
+ "Estimation of Working Capital Lecture 1\n\n"
+ "Estimation of Working Capital Lecture 2\n\n"
+ "Estimation of Working Capital Lecture 3\n\n"
+ "Money Market Lecture 254\n\n"
+ "Money Market Lecture 255\n\n"
+ "Money Market Lecture 256\n\n"
+ "International Trade Lecture 257\n\n"
+ "International Trade Lecture 258\n\n"
+ "International Trade Lecture 259\n"
+ "Terms And Conditions\n"
+ "84749473837373\n"
+ "Random text fifjfofifofjfkfkf\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}