using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w).*?(.@.).*?(.\.\w+)";
string substitution = @"$1****$2***$3";
string input = @"xyzdsdasdas@xyss.com
my_nameis@gmail.com";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}