const regex = /^(\w).*?(.@.).*?(.\.\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w).*?(.@.).*?(.\\.\\w+)', 'gm')
const str = `xyzdsdasdas@xyss.com
my_nameis@gmail.com`;
const subst = `$1****$2***$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);