re = /^(\w).*?(.@.).*?(.\.\w+)/m
str = 'xyzdsdasdas@xyss.com
my_nameis@gmail.com'
subst = '$1****$2***$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result