#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\/\*.*?\*\/"
Local $sString = "int main(/* text */) {" & @CRLF & _
" int i = 0;" & @CRLF & _
" /* hello world */" & @CRLF & _
" return 1;" & @CRLF & _
"} "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")