import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([^ \\>]++) ?[^>]*+>(.*?(?:<([^ \\>]++) ?[^>]*+>(?:[^<]*+|(?2))<\\/ ?\\3>|<[^ \\/>]++ ?\\/>).*?)<\\/ ?\\1>";
final String string = "<bookstore>\n"
+ " <book category=\"CHILDREN\">\n"
+ " <title>Harry Potter</title>\n"
+ " <author>J K. Rowling</author>\n"
+ " <year>2005</year>\n"
+ " <price>29.99</price>\n"
+ " </book>\n"
+ " <book category=\"WEB\">\n"
+ " <title>Learning XML</title>\n"
+ " <author>Erik T. Ray</author>\n"
+ " <year>2003</year>\n"
+ " <price>39.95</price>\n"
+ " </book>\n"
+ "</bookstore>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}