import re
regex = re.compile(r"<([^ \>]++) ?[^>]*+>(.*?(?:<([^ \>]++) ?[^>]*+>(?:[^<]*+|(?2))<\/ ?\3>|<[^ \/>]++ ?\/>).*?)<\/ ?\1>", flags=re.DOTALL)
test_str = ("<bookstore>\n"
" <book category=\"CHILDREN\">\n"
" <title>Harry Potter</title>\n"
" <author>J K. Rowling</author>\n"
" <year>2005</year>\n"
" <price>29.99</price>\n"
" </book>\n"
" <book category=\"WEB\">\n"
" <title>Learning XML</title>\n"
" <author>Erik T. Ray</author>\n"
" <year>2003</year>\n"
" <price>39.95</price>\n"
" </book>\n"
"</bookstore>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")