#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(@[0-9a-zA-Z$_]+)(?=[,)])"
Local $sString = "INSERT INTO tablename (id, name, email) VALUES (@id, @name, @email)" & @CRLF & _
"UPDATE mytable SET id = @id, name = 'myname@id' WHERE id = 1;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")