package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(?\d{3}\)?[- ]\d{3}-\d{4}`)
var str = `888-555-4444
My phone number is (871) 518-1912 okay?
This thing is kuhl and my phone number is 67-19191-191
What was my number? Oh, it's 6710910919
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}