re = /\(?\d{3}\)?[- ]\d{3}-\d{4}/
str = '888-555-4444
My phone number is (871) 518-1912 okay?
This thing is kuhl and my phone number is 67-19191-191
What was my number? Oh, it\'s 6710910919
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end