// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\(?\d{3}\)?[- ]\d{3}-\d{4}").unwrap();
let string = "888-555-4444
My phone number is (871) 518-1912 okay?
This thing is kuhl and my phone number is 67-19191-191
What was my number? Oh, it's 6710910919
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}