# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<xref>[^\d]+)(\d)(<\\/xref)/$1eqvalue$2$3/gm;t' <<< "This is a example string and first line with <xref>id1</xref>then,<xref>id2</xref>and with no line breaks<xref>id3</xref>. This is a second line which has <xref>id4</xref>"