import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(.*?)\\]";
final String string = "Attacks for [1d20+3] damage.\n"
+ "[genderPronoun] is [1d18] years old.\n"
+ "[genderPronoun] is carrying a quiver with [1d8] arrows\n"
+ " ";
final String subst = "1231";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}