$re = '/(Client URL: )(([\w\.\-\+]+:)\/{2}(([\w\d\.]+):([\w\d\.]+))?@?(([a-zA-Z0-9\.\-_]+)(?::(\d{1,5}))?))?(\/(?:[a-zA-Z0-9\.\-\/\+\%]+)?)(?:\?([a-zA-Z0-9=%\-_\.\*&;]+))?(?:#([a-zA-Z0-9\-=,&%;\/\\\\\"\'\?]+)?)?/m';
$str = 'Client URL: https://www.blueridgebankshares.com/corporate-information/corporate-profile/default.aspx
http://user:pass@www.google.com:8000/foo/bar?st=1<=10;#/koo9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);