using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$(\{?(\w+)\}?)(?:\.\$(\{?(\w+)\}?))*?";
string input = @"$FIRSTVAR.${SECONDVAR}LITERAL
${firstvar}.${secondvar}.$thirdvar.${fourth}literal
${firstvar}.literal";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}