re = /\$(\{?(\w+)\}?)(?:\.\$(\{?(\w+)\}?))*?/
str = '$FIRSTVAR.${SECONDVAR}LITERAL
${firstvar}.${secondvar}.$thirdvar.${fourth}literal
${firstvar}.literal'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end