using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"add <capacitor>(?!CAPACITOR_ONPAD_VIA)";
string input = @"add <capacitor>CAPACITOR_ONPAD_VIA
add <capacitor>sdfdsf
add <capacitor>something else
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}