$re = '/add <capacitor>(?!CAPACITOR_ONPAD_VIA)/m';
$str = 'add <capacitor>CAPACITOR_ONPAD_VIA
add <capacitor>sdfdsf
add <capacitor>something else
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);