const regex = /(http[s]?:\/\/)(\S+\/)*(?!=\/$|$)([^\/]+\/)*(?=\/$|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http[s]?:\\\/\\\/)(\\S+\\\/)*(?!=\\\/$|$)([^\\\/]+\\\/)*(?=\\\/$|$)', 'gm')
const str = `https://www.test.ch/posts/mypost-name/
https://www.test.ch/mypost-name/
https://www.test.ch/one/two/three/mypost-name/
https://www.test.ch/one/two/three/mypost-name/noendingslash
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}