re = /(\$\d+\.\d\d)/
str = 'The total it $2.25 Would you like paper or plastic?'
# Print the match result
str.match(re) do |match|
puts match.to_s
end