$re = '/(?<={% highlight %}).*(?={% endhighlight %})/s';
$str = '{% highlight %}ffasd
//some codefasd
fads
fdas
fsad
sda
asdfas
fads
fasf
sa
{% endhighlight %}
{% highlight %}ffasd
//some codefasd
fads
fdas
fsad
sda
asdfas
fads
fasf
sa
{% endhighlight %}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);