#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?:(?<subdomain>[a-z0-9\.\-]*)\.)?(?<domain>(?!com)[a-z0-9\-]{3,}(?=\.[a-z\.]{2,}))\.(?:(?<tld>[a-z\.]{2,})$)"
Local $sString = "apple.orange.banana.clevername.co.uk" & @CRLF & _
"strawberry.apple.orange.banana.clevername.co.uk" & @CRLF & _
"tangerine.com.au" & @CRLF & _
"simple.com" & @CRLF & _
"bit.ly" & @CRLF & _
"something.bit.ly" & @CRLF & _
"clevername.com.au" & @CRLF & _
"hello.world.ninja" & @CRLF & _
"www.something.cancerresearch"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")