# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*_D[1-9]?\d$//gm;t' <<< "04R5714A_D15
04R5714A_D05
04R5714A_D5
04R5714A_D5546
04R5714A_D
"