using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+)><\/\1>";
string input = @"<Item><One>1</One><Two></Two><Three>3</Three><Four></Four></Item>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}