$re = '/<(\w+)><\/\1>/';
$str = '<Item><One>1</One><Two></Two><Three>3</Three><Four></Four></Item>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);