re = /<(\w+)><\/\1>/
str = '<Item><One>1</One><Two></Two><Three>3</Three><Four></Four></Item>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end