import Foundation
let pattern = #"(\d{3})(\d{3})(\d{3})(\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"09551130401"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.$2.$3-$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)