use strict;
my $str = '"!?Text" (1234)
"#1 Text" (1234)
#2 Text (1234) {Some text (#1.1)}
Text (1234)
Some Other Text: More Text here 1234-4321 (1234) (V)';
my $regex = qr/^((.*?) *\((\d+)\))(?: *\{((.*?) *\((.+?)\)) *\})?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}