using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?(?<digits>\d{2}-\d{2}|\d{2,4}).*?$";
string substitution = @"\1";
string input = @"ML 12+ (W166) = 12
FREELANDER II 07+ = 07
Kuga 08-12 = 08-12
CRV 2012+ = 2012
RX270/350 10+ = 10
QASHQAI 2+ =
TRIBECA 05 = 05
XC60 =";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}