re = /(sin|cos|tan|\d+(?:\.\d+)?|[-()+*\/%])/
str = '20.55 * 0.5 * cos(360) + sin 0 * cos 90 + 1 * sin (180 + 90) * 0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end