// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(sin|cos|tan|\d+(?:\.\d+)?|[-()+*/%])").unwrap();
let string = "20.55 * 0.5 * cos(360) + sin 0 * cos 90 + 1 * sin (180 + 90) * 0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}