import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/(content(?!\\/(dam$)))\\/(.*)";
final String string = "/content/asfcew\n"
+ "/content/reddam\n"
+ "/content/usa/texas \n"
+ "and would not recognize \n"
+ "/content/dam\n"
+ " which is good, but alongside it also does not recognize \n"
+ "/content/dam/asdfafa\n"
+ "/content/damred\n"
+ " which is not good.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}