re = /^(?!\s)(?=\w*[A-Z]\w*[A-Z])(?!\s)(?=\w*[a-z]\w*[a-z])(?=\w*[0-9]\w*[0-9])\w*$/
str = 'Password_Must_Have_2Cap_2Smal_2num_no_space'
# Print the match result
str.match(re) do |match|
puts match.to_s
end