# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s"
test_str = ("\n\n"
"Description=Qualcomm Atheros AR8161 PCI-E Gigabit Ethernet Controller (NDIS 6.30)\n"
"MACAddress=FF:FF:FF:FF:FF:FF\n"
"Manufacturer=Qualcomm Atheros\n"
"NetConnectionID=Ethernet\n\n\n"
"Description=Realtek RTL8811AU Wireless LAN 802.11ac USB 2.0 Network Adapter\n"
"MACAddress=FF:FF:FF:FF:FF:FF\n"
"Manufacturer=Realtek Semiconductor Corp.\n"
"NetConnectionID=Wi-Fi\n\n\n"
"Description=VirtualBox Host-Only Ethernet Adapter\n"
"MACAddress=FF:FF:FF:FF:FF:FF\n"
"Manufacturer=Oracle Corporation\n"
"NetConnectionID=VirtualBox Host-Only Network\n\n\n"
"Description=Bluetooth Device (Personal Area Network)\n"
"MACAddress=FF:FF:FF:FF:FF:FF\n"
"Manufacturer=Microsoft\n"
"NetConnectionID=Connexion réseau Bluetooth 2\n\n\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.