re = /@[^@,]*\.([A-Za-z]{2})(?=,|$)/m
str = '001,Francisca,Dr Jhonaci,jhonadr@abc.com,32yearsold,120.238.225.0
002,Lavenda,Bocina,lavenboci@banck.ac.uk,50yearsold,121.186.221.182
003,Laura,Eglington,elinton@python.co.jp,26yearsold,36.55.173.63
004,Timo,Baum,timobaum@tennis.co.cn,22yearsold,121.121.110.10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end