# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!\A)|"title":").*?\K"(?=.*?"\s*,\s*"partid":)//gm;t' <<< "\"title\":\"Гайка 7/16\"-14\" UNC топорна;14H813;P88344 12\"\", \"partid\":\"S.4964\""