$re = '/^(.*?)blog/';
$str = 'https://subdomain.website.com/groups/aa-var-group-members-only-two/blog/2017/10/22/blog-post-3';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);