$re = '~(?=(\d+\s*[/*+-]\d+))\d+~';
$str = '12+34*56/78-90';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);