package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w-]*)\s*:\s*([^;]*)`)
var str = ` border:solid 1px; color:red; background-image: url('http://example.com/image.png')`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}