using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p>[^*?]<a.*?href=.*?javascript:window.history.back.*?>[^*?].*?<\/a>[^*?]<\/p>";
string input = @"<p>
<sdfsdfsfsfsfsfs>
sdfsdfsdf<ssfssfsdf>
<a href=""javascript:window.history.back();"">Document selection</a></p>
<p><a href=""http://www.scei.co.jp/legal/"">Country / Region selection</a></p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}