$re = '/(?P<open_dsq>(?<!\\\\)["\'])(?P<dsq_value>(?s:\\\\.|(?!\\\\|(?P=open_dsq)).)*?)(?P<close_dsq>(?P=open_dsq))/';
$str = '$single_quoted = \'hello world\';
$double_quote = "hi there";
$escaped_single_quote = \'it\\\'s tricky\';
$escaped_double_quotes = "\\"it\'s\\" tricky";
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);