#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\w+?)(?:(,)|$)"
Local $sString = "REP_FINANZGESCHAEFT,REP_OBJEKT,HALLO,ssss"
Local $sSubst = "$1.DWH_JOB_ID$2\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)