// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w+?)(?:(,)|$)").unwrap();
let string = "REP_FINANZGESCHAEFT,REP_OBJEKT,HALLO,ssss";
let substitution = "$1.DWH_JOB_ID$2\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}