$re = '/[a-zA-Z!$.&\d]{4,24}[@][a-zA-Z]{2,}(?:\.edu|\.com|\.net)/';
$str = 'test@school.edu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);