$re = '/(?:https?:\/\/|www\.)\S+/m';
$str = 'http://foo.com
https://foo.com
foo.com
www.foo.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);