re = /(?:https?:\/\/|www\.)\S+/m
str = 'http://foo.com
https://foo.com
foo.com
www.foo.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end