#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b\d{1,2}:\d{2}\b|[,.;:?]+|(?:(?!\b\d{1,2}:\d{2}\b)[^\s,.;:?])+"
Local $sString = "Shall we meet at, let's say, 8:45 AM?"
Local $sSubst = "\n$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)